use strict;
my $str = ' 1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\\s{1})(\\s)(\\d*)(\\s)*(.*?)\\n((\\s{2})(\\d)(\\s*)*(.*?)\\n)[WITH]#$3# $5
$6';
my $regex = qr/^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)/p;
my $subst = '#$3# $5\\n$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";