// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)").unwrap();
let string = " 1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\\s{1})(\\s)(\\d*)(\\s)*(.*?)\\n((\\s{2})(\\d)(\\s*)*(.*?)\\n)[WITH]#$3# $5
$6";
let substitution = "#$3# $5\\n$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}