import Foundation
let pattern = #"^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
1 MASS
2 BLOCKCOUNT
3 SECTOR
4 SYSTEM
SECOND DISPLAY BLOCK REGEX COMMAND
[REPLACEFIRST]^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)[WITH]#$3# $5
$6
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#$3# $5\n$6"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)