# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s{1})(\s)(\d*)(\s)*(.*?)\n((\s{2})(\d)(\s*)*(.*?)\n)"
test_str = (" 1 MASS\n"
" 2 BLOCKCOUNT\n"
" 3 SECTOR\n"
" 4 SYSTEM\n\n"
"SECOND DISPLAY BLOCK REGEX COMMAND\n\n"
"[REPLACEFIRST]^(\\s{1})(\\s)(\\d*)(\\s)*(.*?)\\n((\\s{2})(\\d)(\\s*)*(.*?)\\n)[WITH]#$3# $5\n"
"$6")
subst = "#$3# $5\\n$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.