#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S"
Local $sString = "U.S.A Count U.S.A. " & @CRLF & _
"Sec.of U.S. " & @CRLF & _
"Name:Dr.John Doe " & @CRLF & _
"J.Doe " & @CRLF & _
"1.11 1,000 10--20 10-20 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")