import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d|\\.|\\,]+|[A-Z][\\.|A-Z]+\\b[\\.]*|[\\w]+|\\S";
final String string = "U.S.A Count U.S.A. \n"
+ "Sec.of U.S. \n"
+ "Name:Dr.John Doe \n"
+ "J.Doe \n"
+ "1.11 1,000 10--20 10-20 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}