re = /[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S/
str = 'U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end