using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S";
string input = @"U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}