const regex = /[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d|\\.|\\,]+|[A-Z][\\.|A-Z]+\\b[\\.]*|[\\w]+|\\S', 'g')
const str = `U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}