$re = '/[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S/';
$str = 'U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);