import Foundation
let pattern = #"[\d|\.|\,]+|[A-Z][\.|A-Z]+\b[\.]*|[\w]+|\S"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
U.S.A Count U.S.A.
Sec.of U.S.
Name:Dr.John Doe
J.Doe
1.11 1,000 10--20 10-20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)