#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":\/\/(.*?)\/"
Local $sString = "string: https://www.example.com/test/intro.php return: www.example.com" & @CRLF & _
"" & @CRLF & _
"string: http://www.test.fr/ return: www.test.fr" & @CRLF & _
"" & @CRLF & _
"string: http://mysite.eu/portal/ return: mysite.eu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")