// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":\/\/(.*?)\/").unwrap();
let string = "string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}