import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\/\\/(.*?)\\/";
final String string = "string: https://www.example.com/test/intro.php return: www.example.com\n\n"
+ "string: http://www.test.fr/ return: www.test.fr\n\n"
+ "string: http://mysite.eu/portal/ return: mysite.eu";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}