const regex = /:\/\/(.*?)\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\\/\\\/(.*?)\\\/', 'g')
const str = `string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}