package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:\/\/(.*?)\/`)
var str = `string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}