re = /:\/\/(.*?)\//
str = 'string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end