$re = '/:\/\/(.*?)\//';
$str = 'string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);