using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\/\/(.*?)\/";
string input = @"string: https://www.example.com/test/intro.php return: www.example.com
string: http://www.test.fr/ return: www.test.fr
string: http://mysite.eu/portal/ return: mysite.eu";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}