# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^ \n]+)$/\1 \1,/gm;t' <<< "Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak"