using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ \n]+)$";
string substitution = @"\1 \1,";
string input = @"Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}