$re = '/([^ \n]+)$/m';
$str = 'Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak';
$subst = "\1 \1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;