// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^ \n]+)$").unwrap();
let string = "Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak";
let substitution = "\\1 \\1,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}