re = /([^ \n]+)$/m
str = 'Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak'
subst = '\\1 \\1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result