use strict;
my $str = 'Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak';
my $regex = qr/([^ \n]+)$/mp;
my $subst = '\\1 \\1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";