package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^ \n]+)$`)
var str = `Deepak Kumar
Deepak The powerhouse
Deepak mcapatna
Deepak`
var substitution = "\1 \1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}