#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$"
Local $sString = "http://www.example.com/" & @CRLF & _
"http://www.example.go.com/" & @CRLF & _
"http://www.example.com/contact/" & @CRLF & _
"http://www.example.com/links/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)