# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$"
test_str = ("http://www.example.com/\n"
"http://www.example.go.com/\n"
"http://www.example.com/contact/\n"
"http://www.example.com/links/")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.