re = /^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$/mi
str = 'http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result