$re = '/^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$/mi';
$str = 'http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;