// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$").unwrap();
let string = "http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}