const regex = /^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?im)\\b(?<protocol>https?|ftp):\\\/\\\/(?<domain>[-A-Z0-9.]+)\\\/?$', 'gmi')
const str = `http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);