using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?im)\b(?<protocol>https?|ftp):\/\/(?<domain>[-A-Z0-9.]+)\/?$";
string substitution = @"";
string input = @"http://www.example.com/
http://www.example.go.com/
http://www.example.com/contact/
http://www.example.com/links/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}