import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?im)\\b(?<protocol>https?|ftp):\\/\\/(?<domain>[-A-Z0-9.]+)\\/?$";
final String string = "http://www.example.com/\n"
+ "http://www.example.go.com/\n"
+ "http://www.example.com/contact/\n"
+ "http://www.example.com/links/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}