# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)"//g;t' <<< "\"false\" (\"first\" or \"second\") \"false\" (\"third (with parenthesis)\")"