using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(|(?<!^)\G)[^)""]*\K""([^""]*)""";
string substitution = @"";
string input = @"""false"" (""first"" or ""second"") ""false"" (""third (with parenthesis)"")";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}