import re
regex = re.compile(r"(?:\(|(?<!^)\G)[^)\"]*\K\"([^\"]*)\"")
test_str = "\"false\" (\"first\" or \"second\") \"false\" (\"third (with parenthesis)\")"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)