import Foundation
let pattern = #"(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""false" ("first" or "second") "false" ("third (with parenthesis)")"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)