#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)""
Local $sString = ""false" ("first" or "second") "false" ("third (with parenthesis)")"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)