const regex = /(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\(|(?<!^)\\G)[^)"]*\\K"([^"]*)"', 'g')
const str = `"false" ("first" or "second") "false" ("third (with parenthesis)")`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);