use strict;
my $str = '"false" ("first" or "second") "false" ("third (with parenthesis)")';
my $regex = qr/(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";