# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\[(.*?)\]//g;t' <<< "Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
"