import Foundation
let pattern = #"\s+\[(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)