// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s+\[(.*?)\]").unwrap();
let string = "Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}