$re = '/\s+\[(.*?)\]/';
$str = 'Hi [everybody], I\'m 22 years old, I\'m a student [at a University of Technology] in Vietnam
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;