re = /\s+\[(.*?)\]/
str = 'Hi [everybody], I\'m 22 years old, I\'m a student [at a University of Technology] in Vietnam
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result