package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+\[(.*?)\]`)
var str = `Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}