#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s+\[(.*?)\]"
Local $sString = "Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam " & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)