const regex = new RegExp('\\s+\\[(.*?)\\]', 'g')
const str = `Hi [everybody], I'm 22 years old, I'm a student [at a University of Technology] in Vietnam
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);