# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+\t\K(.+?)(?=\t)/[url=http:\/\/www.website.com\/personell\/$1]$1[\/url]/gm;t' <<< "2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other"